Android StudioをアップデートしたらFlutterが動かなくなった件


久々にAndroid Studioを起動したところ、メジャーバージョンが上がっていました(3.4→4.1)。

とりあえず上げとくかー、くらいの感覚でアップデートしたところ、

_人人人人人人人人人人人人人人人_
 Flutterが動かなくなりました <
 ̄YYYYYYYYYYYYYYY ̄


因みにEvent Logは以下の感じで出力されていました。

9:03    Plugin Error
         Problems found loading plugins:
         Plugin "Flutter" was not loaded: required plugin "Dart" not installed.
         Disable Flutter
         Enable Dart
         Open plugin manager
 9:03    Plugins Suggestion
         Plugin supporting feature (Run Configuration[Flutter]) is currently not installed.
         Configure plugins…
         Ignore Unknown Features


とりあえず、Enable/Disableを切り替えてみたり、Android Sstudioを再起動してみたりしてみましたが、


直 り ま せ ん 。 。 。


依存関係とか、その辺が原因なんですかね?


原因が深堀できるほど知識がないので、FlutterとDartのプラグインをインストールし直すことにしてみました。

まずは、FlutterとDartのプラグインをアンインストールしていきます。

1.(左上の)[File] > [Settings] > [Plugins]を開く
2.[Installed]から"Flutter"を選択
3.Uninstallを実行(下図の右上)

Flutterアンインストール


Dartについても同様にアンインストールを行いました。

依存関係うんぬんかんぬん言われますが、Flutter以外で使った記憶がないので無視してDartもアンインストール。


アンインストール後、再起動。


で、もう一度FlutterとDartをインストールしてみようと思います。

1.(左上の)[File] > [Settings] > [Plugins]を開く
2.Pluginsの検索窓で”Flutter”と検索し、Flutter(恐らく一番目に出てくる)をインストール

Flutterのインストール


Dartもインストールしてね、って言われるのでDartもインストールします。

FlutterをインストールするとDartもインストールするように要求されるので合わせてインストールする。



ここで再びAndroid Studio再起動になります。


再起動後、Dartをenableにしてね、って言われるのでDartをEnableに。
(図の右下の通知アイコンをクリックするとこの画面になります)

再起動後のDartのenable


で、再びAndroid Studio再起動…

何回再起動させるんですか…??


めげずに再起動して、Flutterプロジェクトを開いてみると、、


無事、Flutterプラグインが動いていることを確認できました◎

ホットリロードも動いているので多分オールOKですね◎


最悪Android Studio再インストールまで覚悟していましたが、その前に解決できてよかったです。


終わり。

Leave a Reply

Your email address will not be published. Required fields are marked *